#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(*\d\d\d\)* *-*\/*\d\d\d *-*\/*\d\d\d\d"
Local $sString = "Number to call (514) 723-4383" & @CRLF & _
"The office number is 432-763-3456" & @CRLF & _
"call 643 771-4453 tomorrow." & @CRLF & _
"Jack's number is (765) 452/1243." & @CRLF & _
"The central number is 871/445/6197" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")