import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(*\\d\\d\\d\\)* *-*\\/*\\d\\d\\d *-*\\/*\\d\\d\\d\\d";
final String string = "Number to call (514) 723-4383\n"
+ "The office number is 432-763-3456\n"
+ "call 643 771-4453 tomorrow.\n"
+ "Jack's number is (765) 452/1243.\n"
+ "The central number is 871/445/6197\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}