use strict;
my $str = 'Number to call (514) 723-4383
The office number is 432-763-3456
call 643 771-4453 tomorrow.
Jack\'s number is (765) 452/1243.
The central number is 871/445/6197
';
my $regex = qr/\(*\d\d\d\)* *-*\/*\d\d\d *-*\/*\d\d\d\d/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}