const regex = new RegExp('\\(*\\d\\d\\d\\)* *-*\\/*\\d\\d\\d *-*\\/*\\d\\d\\d\\d', 'gm')
const str = `Number to call (514) 723-4383
The office number is 432-763-3456
call 643 771-4453 tomorrow.
Jack's number is (765) 452/1243.
The central number is 871/445/6197
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}