package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(*\d\d\d\)* *-*\/*\d\d\d *-*\/*\d\d\d\d`)
var str = `Number to call (514) 723-4383
The office number is 432-763-3456
call 643 771-4453 tomorrow.
Jack's number is (765) 452/1243.
The central number is 871/445/6197
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}