// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"QSO:\s+(\d{4,})\s(\w{2,})\s(\d\d\d\d)-(\d\d)-(\d\d)\s(\d\d\d\d)\s([A-Z0-9\/]{3,})\s+(\d{2,3})\s+(\w+)\s+([A-Z0-9\/]{3,})\s+(\d{2,3})\s+(\w+)\s*").unwrap();
let string = "QSO: 21276 PH 2010-10-31 1439 HG6N 59 15 NY4I 59 05 0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}