import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "QSO:\\s+(\\d{4,})\\s(\\w{2,})\\s(\\d\\d\\d\\d)-(\\d\\d)-(\\d\\d)\\s(\\d\\d\\d\\d)\\s([A-Z0-9\\/]{3,})\\s+(\\d{2,3})\\s+(\\w+)\\s+([A-Z0-9\\/]{3,})\\s+(\\d{2,3})\\s+(\\w+)\\s*";
final String string = "QSO: 21276 PH 2010-10-31 1439 HG6N 59 15 NY4I 59 05 0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}