$re = '/QSO:\s+(\d{4,})\s(\w{2,})\s(\d\d\d\d)-(\d\d)-(\d\d)\s(\d\d\d\d)\s([A-Z0-9\/]{3,})\s+(\d{2,3})\s+(\w+)\s+([A-Z0-9\/]{3,})\s+(\d{2,3})\s+(\w+)\s*/';
$str = 'QSO: 21276 PH 2010-10-31 1439 HG6N 59 15 NY4I 59 05 0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);