use strict;
my $str = 'QSO: 21276 PH 2010-10-31 1439 HG6N 59 15 NY4I 59 05 0';
my $regex = qr/QSO:\s+(\d{4,})\s(\w{2,})\s(\d\d\d\d)-(\d\d)-(\d\d)\s(\d\d\d\d)\s([A-Z0-9\/]{3,})\s+(\d{2,3})\s+(\w+)\s+([A-Z0-9\/]{3,})\s+(\d{2,3})\s+(\w+)\s*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}