const regex = /QSO:\s+(\d{4,})\s(\w{2,})\s(\d\d\d\d)-(\d\d)-(\d\d)\s(\d\d\d\d)\s([A-Z0-9\/]{3,})\s+(\d{2,3})\s+(\w+)\s+([A-Z0-9\/]{3,})\s+(\d{2,3})\s+(\w+)\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('QSO:\\s+(\\d{4,})\\s(\\w{2,})\\s(\\d\\d\\d\\d)-(\\d\\d)-(\\d\\d)\\s(\\d\\d\\d\\d)\\s([A-Z0-9\\\/]{3,})\\s+(\\d{2,3})\\s+(\\w+)\\s+([A-Z0-9\\\/]{3,})\\s+(\\d{2,3})\\s+(\\w+)\\s*', 'g')
const str = `QSO: 21276 PH 2010-10-31 1439 HG6N 59 15 NY4I 59 05 0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}