using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"QSO:\s+(\d{4,})\s(\w{2,})\s(\d\d\d\d)-(\d\d)-(\d\d)\s(\d\d\d\d)\s([A-Z0-9\/]{3,})\s+(\d{2,3})\s+(\w+)\s+([A-Z0-9\/]{3,})\s+(\d{2,3})\s+(\w+)\s*";
string input = @"QSO: 21276 PH 2010-10-31 1439 HG6N 59 15 NY4I 59 05 0";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}