package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`QSO:\s+(\d{4,})\s(\w{2,})\s(\d\d\d\d)-(\d\d)-(\d\d)\s(\d\d\d\d)\s([A-Z0-9\/]{3,})\s+(\d{2,3})\s+(\w+)\s+([A-Z0-9\/]{3,})\s+(\d{2,3})\s+(\w+)\s*`)
var str = `QSO: 21276 PH 2010-10-31 1439 HG6N 59 15 NY4I 59 05 0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}