// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:http:\/\/)(.*?)\/(.+?)(?:\/|\?|\#|$|\n)\w*.jpg").unwrap();
let string = "<div style=\"padding-right: 16px;\"> <img class=\"img-thumbnail gamedetailthumb\" src=\"http://images.cdn.spilcloud.com/thumbs-1-5/200X120_162615.jpg\"> <img class=\"img-thumbnail gamedetailthumb\" src=\"http://images.cdn.spilcloud.com/thumbs-1-5/120X90_162615.jpg\"> <img class=\"img-thumbnail gamedetailthumb\" src=\"http://images.cdn.spilcloud.com/thumbs-1-5/100X75_162615.jpg\"> </div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}