re = /(?:http:\/\/)(.*?)\/(.+?)(?:\/|\?|\#|$|\n)\w*.jpg/
str = '<div style="padding-right: 16px;"> <img class="img-thumbnail gamedetailthumb" src="http://images.cdn.spilcloud.com/thumbs-1-5/200X120_162615.jpg"> <img class="img-thumbnail gamedetailthumb" src="http://images.cdn.spilcloud.com/thumbs-1-5/120X90_162615.jpg"> <img class="img-thumbnail gamedetailthumb" src="http://images.cdn.spilcloud.com/thumbs-1-5/100X75_162615.jpg"> </div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end