using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:http:\/\/)(.*?)\/(.+?)(?:\/|\?|\#|$|\n)\w*.jpg";
string input = @"<div style=""padding-right: 16px;""> <img class=""img-thumbnail gamedetailthumb"" src=""http://images.cdn.spilcloud.com/thumbs-1-5/200X120_162615.jpg""> <img class=""img-thumbnail gamedetailthumb"" src=""http://images.cdn.spilcloud.com/thumbs-1-5/120X90_162615.jpg""> <img class=""img-thumbnail gamedetailthumb"" src=""http://images.cdn.spilcloud.com/thumbs-1-5/100X75_162615.jpg""> </div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}