import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:http:\\/\\/)(.*?)\\/(.+?)(?:\\/|\\?|\\#|$|\\n)\\w*.jpg";
final String string = "<div style=\"padding-right: 16px;\"> <img class=\"img-thumbnail gamedetailthumb\" src=\"http://images.cdn.spilcloud.com/thumbs-1-5/200X120_162615.jpg\"> <img class=\"img-thumbnail gamedetailthumb\" src=\"http://images.cdn.spilcloud.com/thumbs-1-5/120X90_162615.jpg\"> <img class=\"img-thumbnail gamedetailthumb\" src=\"http://images.cdn.spilcloud.com/thumbs-1-5/100X75_162615.jpg\"> </div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}