package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:http:\/\/)(.*?)\/(.+?)(?:\/|\?|\#|$|\n)\w*.jpg`)
var str = `<div style="padding-right: 16px;"> <img class="img-thumbnail gamedetailthumb" src="http://images.cdn.spilcloud.com/thumbs-1-5/200X120_162615.jpg"> <img class="img-thumbnail gamedetailthumb" src="http://images.cdn.spilcloud.com/thumbs-1-5/120X90_162615.jpg"> <img class="img-thumbnail gamedetailthumb" src="http://images.cdn.spilcloud.com/thumbs-1-5/100X75_162615.jpg"> </div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}