use strict;
my $str = '<div style="padding-right: 16px;"> <img class="img-thumbnail gamedetailthumb" src="http://images.cdn.spilcloud.com/thumbs-1-5/200X120_162615.jpg"> <img class="img-thumbnail gamedetailthumb" src="http://images.cdn.spilcloud.com/thumbs-1-5/120X90_162615.jpg"> <img class="img-thumbnail gamedetailthumb" src="http://images.cdn.spilcloud.com/thumbs-1-5/100X75_162615.jpg"> </div>';
my $regex = qr/(?:http:\/\/)(.*?)\/(.+?)(?:\/|\?|\#|$|\n)\w*.jpg/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}