# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:http:\/\/)(.*?)\/(.+?)(?:\/|\?|\#|$|\n)\w*.jpg"
test_str = "<div style=\"padding-right: 16px;\"> <img class=\"img-thumbnail gamedetailthumb\" src=\"http://images.cdn.spilcloud.com/thumbs-1-5/200X120_162615.jpg\"> <img class=\"img-thumbnail gamedetailthumb\" src=\"http://images.cdn.spilcloud.com/thumbs-1-5/120X90_162615.jpg\"> <img class=\"img-thumbnail gamedetailthumb\" src=\"http://images.cdn.spilcloud.com/thumbs-1-5/100X75_162615.jpg\"> </div>"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.