$re = '/USE\s(?P<db>\[\w+\]);?\s*
CREATE VIEW (?P<schema>\[\w+\])\.(?P<name>\[\w+\])
AS\s*
(?P<sql>.+)/is';
$str = 'USE [db_name];
CREATE VIEW [schema_name].[view_name]
AS
WITH cte AS (
SELECT * from A
)
select * from cte;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);