#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)USE\s(?P<db>\[\w+\]);?\s*" & @CRLF & _
"CREATE VIEW (?P<schema>\[\w+\])\.(?P<name>\[\w+\])" & @CRLF & _
"AS\s*" & @CRLF & _
"(?P<sql>.+)"
Local $sString = "USE [db_name];" & @CRLF & _
"" & @CRLF & _
"CREATE VIEW [schema_name].[view_name]" & @CRLF & _
"AS" & @CRLF & _
"WITH cte AS (" & @CRLF & _
"SELECT * from A " & @CRLF & _
")" & @CRLF & _
"select * from cte;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")