package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)USE\s(?P<db>\[\w+\]);?\s*
CREATE VIEW (?P<schema>\[\w+\])\.(?P<name>\[\w+\])
AS\s*
(?P<sql>.+)`)
var str = `USE [db_name];
CREATE VIEW [schema_name].[view_name]
AS
WITH cte AS (
SELECT * from A
)
select * from cte;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}