use strict;
my $str = 'USE [db_name];
CREATE VIEW [schema_name].[view_name]
AS
WITH cte AS (
SELECT * from A
)
select * from cte;';
my $regex = qr/USE\s(?P<db>\[\w+\]);?\s*
CREATE VIEW (?P<schema>\[\w+\])\.(?P<name>\[\w+\])
AS\s*
(?P<sql>.+)/isp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}