import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "USE\\s(?P<db>\\[\\w+\\]);?\\s*\n"
+ "CREATE VIEW (?P<schema>\\[\\w+\\])\\.(?P<name>\\[\\w+\\])\n"
+ "AS\\s*\n"
+ "(?P<sql>.+)";
final String string = "USE [db_name];\n\n"
+ "CREATE VIEW [schema_name].[view_name]\n"
+ "AS\n"
+ "WITH cte AS (\n"
+ "SELECT * from A \n"
+ ")\n"
+ "select * from cte;";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}