using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"USE\s(?P<db>\[\w+\]);?\s*
CREATE VIEW (?P<schema>\[\w+\])\.(?P<name>\[\w+\])
AS\s*
(?P<sql>.+)";
string input = @"USE [db_name];
CREATE VIEW [schema_name].[view_name]
AS
WITH cte AS (
SELECT * from A
)
select * from cte;";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}