const regex = /USE\s(?P<db>\[\w+\]);?\s*
CREATE VIEW (?P<schema>\[\w+\])\.(?P<name>\[\w+\])
AS\s*
(?P<sql>.+)/gis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('USE\\s(?P<db>\\[\\w+\\]);?\\s*
CREATE VIEW (?P<schema>\\[\\w+\\])\\.(?P<name>\\[\\w+\\])
AS\\s*
(?P<sql>.+)', 'gis')
const str = `USE [db_name];
CREATE VIEW [schema_name].[view_name]
AS
WITH cte AS (
SELECT * from A
)
select * from cte;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}