// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^data:(?<type>[\w\/\-\.]+)?(?:;(?<encoding>\w+))?,(?<data>.*)").unwrap();
let string = "data:[<mediatype>][;base64],<data>
data:,Hello%2C%20World%21
data:text/plain;base64,SGVsbG8sIFdvcmxkIQ==
data:text/html,%3Ch1%3EHello%2C%20World%21%3C%2Fh1%3E
data:text/html,<script>alert('hi');</script>
data:image/png;base64,iVBORw0KGgoAA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}