const regex = /^data:(?<type>[\w\/\-\.]+)?(?:;(?<encoding>\w+))?,(?<data>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^data:(?<type>[\\w\\\/\\-\\.]+)?(?:;(?<encoding>\\w+))?,(?<data>.*)', 'gm')
const str = `data:[<mediatype>][;base64],<data>
data:,Hello%2C%20World%21
data:text/plain;base64,SGVsbG8sIFdvcmxkIQ==
data:text/html,%3Ch1%3EHello%2C%20World%21%3C%2Fh1%3E
data:text/html,<script>alert('hi');</script>
data:image/png;base64,iVBORw0KGgoAA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}