# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^data:(?<type>[\w\/\-\.]+)?(?:;(?<encoding>\w+))?,(?<data>.*)"
test_str = ("data:[<mediatype>][;base64],<data>\n"
"data:,Hello%2C%20World%21\n"
"data:text/plain;base64,SGVsbG8sIFdvcmxkIQ==\n"
"data:text/html,%3Ch1%3EHello%2C%20World%21%3C%2Fh1%3E\n"
"data:text/html,<script>alert('hi');</script>\n"
"data:image/png;base64,iVBORw0KGgoAA")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.