import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^data:(?<type>[\\w\\/\\-\\.]+)?(?:;(?<encoding>\\w+))?,(?<data>.*)";
final String string = "data:[<mediatype>][;base64],<data>\n"
+ "data:,Hello%2C%20World%21\n"
+ "data:text/plain;base64,SGVsbG8sIFdvcmxkIQ==\n"
+ "data:text/html,%3Ch1%3EHello%2C%20World%21%3C%2Fh1%3E\n"
+ "data:text/html,<script>alert('hi');</script>\n"
+ "data:image/png;base64,iVBORw0KGgoAA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}