$re = '/^data:(?<type>[\w\/\-\.]+)?(?:;(?<encoding>\w+))?,(?<data>.*)/m';
$str = 'data:[<mediatype>][;base64],<data>
data:,Hello%2C%20World%21
data:text/plain;base64,SGVsbG8sIFdvcmxkIQ==
data:text/html,%3Ch1%3EHello%2C%20World%21%3C%2Fh1%3E
data:text/html,<script>alert(\'hi\');</script>
data:image/png;base64,iVBORw0KGgoAA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);