package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^data:(?<type>[\w\/\-\.]+)?(?:;(?<encoding>\w+))?,(?<data>.*)`)
var str = `data:[<mediatype>][;base64],<data>
data:,Hello%2C%20World%21
data:text/plain;base64,SGVsbG8sIFdvcmxkIQ==
data:text/html,%3Ch1%3EHello%2C%20World%21%3C%2Fh1%3E
data:text/html,<script>alert('hi');</script>
data:image/png;base64,iVBORw0KGgoAA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}