import Foundation
let pattern = #"(")(?![^<>]*>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"I want to replace the " caracter, ignoring<span id="ID"> that "-ones inside </span> the "HTML tags" to apply some tags"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<tag>$1</tag>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)