use strict;
my $str = 'I want to replace the " caracter, ignoring<span id="ID"> that "-ones inside </span> the "HTML tags" to apply some tags';
my $regex = qr/(")(?![^<>]*>)/mp;
my $subst = '<tag>$1</tag>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";