const regex = /(")(?![^<>]*>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(")(?![^<>]*>)', 'gm')
const str = `I want to replace the " caracter, ignoring<span id="ID"> that "-ones inside </span> the "HTML tags" to apply some tags`;
const subst = `<tag>$1</tag>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);