re = /(")(?![^<>]*>)/m
str = 'I want to replace the " caracter, ignoring<span id="ID"> that "-ones inside </span> the "HTML tags" to apply some tags'
subst = '<tag>$1</tag>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result