using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"("")(?![^<>]*>)";
string substitution = @"<tag>$1</tag>";
string input = @"I want to replace the "" caracter, ignoring<span id=""ID""> that ""-ones inside </span> the ""HTML tags"" to apply some tags";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}