$re = '/(")(?![^<>]*>)/m';
$str = 'I want to replace the " caracter, ignoring<span id="ID"> that "-ones inside </span> the "HTML tags" to apply some tags';
$subst = "<tag>$1</tag>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;