import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\")(?![^<>]*>)";
final String string = "I want to replace the \" caracter, ignoring<span id=\"ID\"> that \"-ones inside </span> the \"HTML tags\" to apply some tags";
final String subst = "<tag>$1</tag>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}