import Foundation
let pattern = #"^https?:\/\/[A-Za-z0-9:.]*([\/]{1}.*\/?)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://x1m/some-page/sdfsdada?=123qdsadsaDasd123`12/123123 12313`12 asda"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}