package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^https?:\/\/[A-Za-z0-9:.]*([\/]{1}.*\/?)$`)
var str = `https://x1m/some-page/sdfsdada?=123qdsadsaDasd123\`12/123123 12313\`12 asda`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}