using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/[A-Za-z0-9:.]*([\/]{1}.*\/?)$";
string input = @"https://x1m/some-page/sdfsdada?=123qdsadsaDasd123`12/123123 12313`12 asda";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}