re = /^https?:\/\/[A-Za-z0-9:.]*([\/]{1}.*\/?)$/
str = 'https://x1m/some-page/sdfsdada?=123qdsadsaDasd123`12/123123 12313`12 asda'
# Print the match result
str.match(re) do |match|
puts match.to_s
end