$re = '/^https?:\/\/[A-Za-z0-9:.]*([\/]{1}.*\/?)$/';
$str = 'https://x1m/some-page/sdfsdada?=123qdsadsaDasd123`12/123123 12313`12 asda';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);