use strict;
my $str = 'https://x1m/some-page/sdfsdada?=123qdsadsaDasd123`12/123123 12313`12 asda';
my $regex = qr/^https?:\/\/[A-Za-z0-9:.]*([\/]{1}.*\/?)$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}