const regex = new RegExp('^https?:\\/\\/[A-Za-z0-9:.]*([\\/]{1}.*\\/?)$', '')
const str = `https://x1m/some-page/sdfsdada?=123qdsadsaDasd123\`12/123123 12313\`12 asda`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}