// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)%([a-zA-Z-_])*\s?\{[\s,]*\n(.*?)\n\}\s*\n").unwrap();
let string = "%abstract-class {
font-family: Verdana;
}
%abstract-class {
font-family: Verdana;
}
%abstract-class{
font-family: Verdana;
font-site: 100%;
}
bla {
lkdjkjd: 10px;
}
%abstract-class {
.abstract-class {
font-family: Verdana;
}
a,
a:hover {
}
}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}