import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "%([a-zA-Z-_])*\\s?\\{[\\s,]*\\n(.*?)\\n\\}\\s*\\n";
final String string = "%abstract-class {\n"
+ " font-family: Verdana;\n"
+ "}\n\n"
+ "%abstract-class {\n"
+ " font-family: Verdana;\n"
+ "}\n\n"
+ "%abstract-class{\n"
+ " font-family: Verdana;\n"
+ " font-site: 100%;\n"
+ "} \n\n"
+ "bla {\n"
+ "lkdjkjd: 10px;\n"
+ "}\n\n"
+ "%abstract-class {\n"
+ " .abstract-class {\n"
+ " font-family: Verdana;\n"
+ " }\n"
+ " a,\n"
+ " a:hover {\n\n"
+ " }\n"
+ "} \n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}