package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)%([a-zA-Z-_])*\s?\{[\s,]*\n(.*?)\n\}\s*\n`)
var str = `%abstract-class {
font-family: Verdana;
}
%abstract-class {
font-family: Verdana;
}
%abstract-class{
font-family: Verdana;
font-site: 100%;
}
bla {
lkdjkjd: 10px;
}
%abstract-class {
.abstract-class {
font-family: Verdana;
}
a,
a:hover {
}
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}