$re = '/%([a-zA-Z-_])*\s?\{[\s,]*\n(.*?)\n\}\s*\n/s';
$str = '%abstract-class {
font-family: Verdana;
}
%abstract-class {
font-family: Verdana;
}
%abstract-class{
font-family: Verdana;
font-site: 100%;
}
bla {
lkdjkjd: 10px;
}
%abstract-class {
.abstract-class {
font-family: Verdana;
}
a,
a:hover {
}
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);